Cerrar Publicidad

Contenido

TERMINAL SERVER. 3

DHCP. 4

Acceso remoto con VNC. 5

Acceso remoto con SSH.. 6

FTP seguro. 7

Túneles locales SSH.. 8

Túnele SSH con Escritorio Remoto. 9

Túnele SSH con Apache. 10

DNS maestro. 11

DNS esclavo. 13

DNS caché. 15

Webmin. 16

Servidor NFS. 17

SERVIDOR. 17

CLIENTE. 17

Servidor Samba. 18

Cliente Samba. 18

Controlador de dominio Samba. 19

Servidor. 19

Cliente Windows. 20

Borrado, copia y restauración de router’s y switch’s. 21

VLAN.. 22

VTP SERVER Y VTP CLIENT. 24

Inter VLAN.. 26

Spanning-tree. 28

NAT Estático y dinámico. 30

NAT CON RIP. 32

NAT CON PUNTO DE ACCESO WIFFI 34

NAT/DHCP y OSPF. 35

DHCP-RELAY. 37

DHCP y OSPF. 38

Encaminamiento por IP entre pcs. 39

Encaminamiento estático. 40

OSPF. 42

RIP. 44

WIRELESS. 46

Modo Bridge. 46

Modo Wireless Client. 47

Modo Multipoint Bridge. 48

Posible ejercicio de examen. 49


TERMINAL SERVER

1. Comprobar que la opción de escritorio remoto en “Propiedades del sistema>Acceso remoto>Escritorio remotoàHabilitar Escritorio remoto en este equipo”, está activada.

2. Si deseamos permitir el acceso mediante la Conexión a Escritorio Remoto a otros usuarios que no sean el propio Administrador de nuestro servidor, en la pestaña "Acceso Remoto" pulsaremos sobre el botón "Seleccionar usuarios remotos..." e indicaremos los usuarios a los que deseamos dar acceso.

3. Comprobar que el firewall está desactivado.

4. En “Panel de Control>Herramientas Administrativas>Servicios>Servicios de Terminal Server”, copiar la ruta de acceso al ejecutable para pegarla en una ventana de consola (Ejecutar à cmd)

5. En el cliente:

a. Desde un Pc (Windows no XP) Descargar el cliente para escritorio remoto que estará en la pagina (en XP no hace falta descargar ni instalar el cliente): http://www.microsoft.com/windowsxp/downloads/tools/rdclientdl.mspx

(No XP)Una vez instalado el cliente ejecutarlo desde” Inicio> Programas>Accessorios >Conexión a escritorio remoto”.

Si estabamos en XP, ejecutarlo desde "Inicio >Programas>Accesorios> Comunicaciones> Conexión a Escritorio Remoto".

En la ventana que se abrirá una ventana donde podremos introducir la dirección a la que queremos conectarnos remotamente.

b. Ejecutar en un Pc (linux)

rdesktop –a 16 –g 800x600

O también

KRDC > escritorio remoto de Windows > IP_SERVER:3389


DHCP

1. Instalar servidor DHCP:

apt-get install dhcp3-server

El servidor deberá configurarse con una IP estática (ifconfig eth3 192.168.1.1 netmask 255.255.255.0) y se recomienda no usar la red pública, hacerlo en la interna.

2. Editar el archive de configuración:

kate /etc/dhcp3/dhcpd.conf &

Por ejemplo, se pondría:

subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.60 192.168.1.80; # Rango de la 60 a la 80 inclusive
option broadcast-address 192.168.1.255; # Dirección de difusión
option routers 192.168.1.254; # Puerta de enlace
option domain-name-servers 80.58.0.33; # DNS (ej: el de telefónica)
default-lease-time 7200; # Tiempo de cesion
}

3. Crear el archivo /etc/dhcp3/dhcpd.leases, vacío (touch dhcpd.leases)

4. Arrancar, parar o reiniciar el servicio: (puede variar según Ubuntu o Debian)

/etc/init.d/dhcp3-server start à Arrancar

/etc/init.d/dhcp3-server stop à Parar

/etc/init.d/dhcp3-server restart à Reiniciar

(/usr/sbin/dhcpd3 start/stop/restart)

5. Para probar el servicio DHCP en el cliente, ejecutamos dhclient sobre la interfaz de red interna, por ejemplo:

Dhclient eth3 o ifconfig eth3 dhcp

Nos deberá dar una dirección dentro del rango que le hemos especificado en el rango del servidor y el servidor DHCP será la dirección del servidor.


Acceso remoto con VNC

Ø Instalar el servidor y cliente VNC con:

apt-get install vnc4server

apt-get install vncviewer

Ø Arrancar VNC en el servidor à vnc4server

Poner contraseña al VNC à vncpasswd

Ejecutar VNC en el servidor à vnc4server &

Ø Probar en el cliente VNC à vncviewer IP_SERVIDOR:1

También se puede probar en à Aplicaciones, internet, krdc à vnc:/IP_SERVIDOR:1

Ø Para salir de VNC desde el remoto, ejecutamos à vnc4server –kill :1

1. Instalar el servidor y cliente VNC con:

apt-get install tightvncserver

apt-get install xtightvncviewer

2. Arrancar VNC en el servidor à tightvncserver :2 –geometry 800x600 –depth 24 (el :2 quiere decir el numero de display, si no ponemos parámetros nos indica luego el display asociado)

3. Probar en el cliente VNC à xtightvncviewer ip_servidor:nºdisplay (xtightvncviewer 158.49.92.10:2)

Una opción mejor es probarlo con el programa” kdrc” e indicar en el diálogo que se nos abre vnc:/dir_servidor:nº display (vnc:/158.49.92.10:2)

Se nos abrirá el terminal remoto y en el podremos comprobar donde estamos mirando los archivos o haciendo un shutdown -r, que reiniciará la maquina remota.


Acceso remoto con SSH

1. Instalar el servidor y el cliente SSH con:

apt-get install openssh-server

apt-get install ssh

2. Arrancar el servicio à /etc/init.d/ssh restart

Parar servidor à /etc/init.d/ssh stop

Para conectar desde un pc cliente, al servidor, mediante SSH: (Putty en windows)

ssh

ssh @ à conectar con nombre de usuario especificado

3. Para copiar un archivo del servidor desde nuestro pc: (-r para carpetas enteras)

scp @:

A la inversa:

scp @:

Crear y copiar el certificado:

a. En el archivo de configuración del servidor debemos tener la siguiente opción activada: (/etc/ssh/sshd_config)

PubkeyAuthentication yes

b. Generaremos el certificado en el cliente: ssh-keygen –t rsa

c. Copiamos el certificado del usuario en el servidor:

scp ~/.ssh/id_rsa.pub @:~/.ssh/authorized_keys

(~ àCon Alt Gr-4)

De este modo, al conectarnos no necesitaremos poner la contraseña.

Ø Otra forma más fácil de iniciar en modo gráfico con ssh à

ssh –L -X

4. Aplicaciones graficas con ssh (X): (cygwin)

a. Habilitar la opción siguiente en el servidor (/etc/ssh/sshd_config):

X11Forwarding yes

b. Redirigimos y ejecutamos:

Ssh –X cnice@


FTP seguro

1. Instalar:

apt-get install vsftpd

apt-get install ssh (si no está instalado ssh)

2. Editar el archivo /etc/vsftpd.conf:

Local_enable = yes

El erchivo /etc/ftpusers contiene los usuarios que tienen acceso al ftp

3. Reiniciar el servicio ssh:

/etc/init.d/ssh restart

4. Probar en el cliente abriendo un navegador (Konqueror por ejemplo, que permite ftp seguro), poniendo:

Sftp://usuario@dir_servidor

(sftp://puesto@158.49.92.149)

Se abrirá visualizarán los directorios del servidor, donde podremos copiar, pegar, etc…

Túneles locales SSH

Tunel SSH a través de “Intermedio”


CLIENTE

158.49.92.10


1. Instalar:

Servidor VNC destino à apt-get install vnc4server

Intermedio àapt-get install ssh (si no está instalado)

Cliente à apt-get install ssh (Si no está instalado)

2. Ejecutar:

Intermedio à/etc/init.d/ssh restart

Servidor VNC destino à vnc4server à contraseña vnc à nº de display (p.e. 2)

Ver en qué puerto está escuchando vnc (5901?)(con netstat -puta).

Cliente à ssh –L 5902:158.49.92.12:5901 root@158.49.92.11 à creado el túnel ssh

ó ssh –f –L 5902:158.49.92.12:5901 root@158.49.92.11 sleep 7200

Para probar vnc por ssh en el cliente basta con vncviewer localhost:2

o abrir kdrc

y ejecutar vnc:/localhost:2


Túnele SSH con Escritorio Remoto

SERVER

1. Comprobar que la opción de escritorio remoto en “Propiedades del sistema>Acceso remoto>Escritorio remotoàHabilitar Escritorio remoto en este equipo”, está activada.

2. Si deseamos permitir el acceso mediante la Conexión a Escritorio Remoto a otros usuarios que no sean el propio Administrador de nuestro servidor, en la pestaña "Acceso Remoto" pulsaremos sobre el botón "Seleccionar usuarios remotos..." e indicaremos los usuarios a los que deseamos dar acceso.

3. Comprobar que el firewall está desactivado.

4. En “Panel de Control>Herramientas Administrativas>Servicios>Servicios de Terminal Server”, copiar la ruta de acceso al ejecutable para pegarla en una ventana de consola (Ejecutar à cmd)

INTERMEDIO

1. /etc/init.d/ssh restart

CLIENTE

1. ssh –f –L 9999:IP_SERVER:3389 USER_INTERMEDIO@I_INTERMEDIO sleep 7200

2. KRDC > Escritorio de windows > localhost:9999


Túnele SSH con Apache

SERVER

1. apt-get install apache2

2. /etc/init.d/apache restart

INTERMEDIO

1. /etc/init.d/ssh restart

CLIENTE

1. ssh –f –L 9999:IP_SERVER:80 USER_INTERMEDIO@I_INTERMEDIO sleep 7200

2. En el navegador: http://localhost:9999


DNS maestro

1. Instalar: apt-get install bind9

2. Establecer las direcciones estáticas para la tarjeta de red interna:

ifconfig eth3 192.168.1.10 netmask 255.255.255.0 up (maestro)

ifconfig eth3 192.168.1.11 netmask 255.255.255.0 up (pc1)

ifconfig eth3 192.168.1.12 netmask 255.255.255.0 up (pc2)

3. Configurar:

Kate /etc/bind/named.conf.local &

zone “mydns.com”{

type master;

file “/etc/bind/mydns.db”;

};

zone “1.168.192.in-addr.arpa”{

type master;

file “/etc/bind/192.rev”;

};

4. Crear archivos de zona directa e inversa:

Zona directa: mydns.db

@ IN SOA mydns.com. root.mydns.com. (
1 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Default TTL

@ IN NS dns.mydns.com.

pc1 IN A 192.168.1.11
pc2 IN A 192.168.1.12
dns IN A 192.168.1.10

Zona inversa: 192.rev

@ IN SOA mydns.com. root.mydns.com. (
1 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Default TTL

@ IN NS dns.mydns.com.

11 IN PTR pc1.mydns.com.

12 IN PTR pc2.mydns.com.
10 IN PTR dns.mydns.com.

5. Editar (Servidor):

Kate /etc/resolv.conf & ànameserver 127.0.0.1

Search mydns.com

6. Editar (Cliente):

Kate /etc/resolv.conf & ànameserver 192.168.1.10

7. Arrancar el servicio:

/etc/init.d/bind9 restart

(En el caso de que saliera error al arrancar el demonio puede ser por errores en los ficheros, ya que son importantes las tabulaciones y las minúsculas)(Ver el archivo /var/log/syslog donde al final se indicará el error)

Para probar el servicio basta con: host pc1.mydns.com (directo)

ó/y host 192.168.1.10 (inversa)


DNS esclavo

1. Instalar: apt-get install bind9 (en maestro y esclavo)

2. Establecer las direcciones estáticas para la tarjeta de red interna:

ifconfig eth3 192.168.1.10 netmask 255.255.255.0 up (maestro)

ifconfig eth3 192.168.1.11 netmask 255.255.255.0 up (esclavo)

ifconfig eth3 192.168.1.12 netmask 255.255.255.0 up (pc2)

3. Configurar maestro:

Kate /etc/bind/named.conf.local &

zone “mydns.com”{

type master;

file “/etc/bind/mydns.db”;

also-notify {192.168.1.11;};

};

zone “1.168.192.in-addr.arpa”{

type master;

file “/etc/bind/192.rev”;

also-notify {192.168.1.11;};

};

4. Crear archivos de zona directa e inversa para el maestro:

Zona directa: mydns.db

@ IN SOA mydns.com. root.mydns.com. (
1 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Default TTL

@ IN NS dns.mydns.com.
@ IN NS dns2.mydns.com.


dns2 IN A 192.168.1.11
pc2 IN A 192.168.1.12
dns IN A 192.168.1.10

Zona inversa: 192.rev

@ IN SOA mydns.com. root.mydns.com. (
1 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Default TTL

@ IN NS dns.mydns.com.
@ IN NS dns2.mydns.com.


11 IN PTR dns2.mydns.com.

12 IN PTR pc2.mydns.com.
10 IN PTR dns.mydns.com.

5. Editar (maestro):

Kate /etc/resolv.conf & ànameserver 127.0.0.1

nameserver 192.168.1.11

Search mydns.com

6. Configurar esclavo:

Kate /etc/bind/named.conf.local &

zone “mydns.com”{

type slave;

file “/etc/bind/mydns.db”;

masters {192.168.1.10;};

};

zone “1.168.192.in-addr.arpa”{

type slave;

file “/etc/bind/192.rev”;

masters {192.168.1.10;};

};

7. Crear archivos de zona directa e inversa para el esclavo: los mismos que los del maestro. (mydns.db y 192.rev en /etc/bind/)

8. Editar (esclavo):

Kate /etc/resolv.conf & ànameserver 192.168.1.10

nameserver 192.168.1.11

search mydns.com

9. Editar (cliente):

Kate /etc/resolv.conf & ànameserver 192.168.1.10

nameserver 192.168.1.11

10. Arrancar el servicio en el esclavo:

/etc/init.d/bind9 restart

11. Parar el servicio en el maestro, si estuviera activo:

/etc/init.d/bind9 stop

(En el caso de que saliera error al arrancar el demonio puede ser por errores en los ficheros, ya que son importantes las tabulaciones y las minúsculas)(Ver el archivo /var/log/syslog donde al final se indicará el error)

Para probar el servicio basta con: host pc1.mydns.com (directa)

ó/y host 192.168.1.10 (inversa)

Para probar el dns secundario en el pc2 en el /etc/resolv.conf comentar la ip del servidor para que asi salte el secundario.

DNS caché

1. Configurar maestro, como se ha indicado en el apartado inicial de DNS.

2. Configurar maestro:

Kate /etc/bind/named.conf.options &

(Ponemos las DNS de telefónica como ejemplo porque así es como se comprobó que funcionaba)

Forwarders {

195.235.96.90; 195.235.113.3;

};

3. Editar (cliente):

Kate /etc/resolv.conf & ànameserver 192.168.1.10

4. Desde el cliente:

host www.google.es à nos aparecerá la dirección correspondiente a google.

APUNTE: Mirar el fichero /etc/nsswitch.conf y cambiar la línea de services….


Webmin

1. Bajar de la página http://sourceforge.net/project/downloading.php?groupname=webadmin&filename=webmin-1.450.tar.gz&use_mirror=heanet el “.tar” de webmin.

2. Descomprimir el archivo: tar –zxvf webmin-1.450.tar.gz

3. Ejecutar el fichero descomprimido. ./webmin-1.450.bin o ./setup.sh à login, password, puerto = 10000 (p.e.)…

4. Probar que ha sido bien instalado àEn un navegador: http://localhost:10000

5. Para instalar el plugin de java:

a. Descargar el archivo .bin de la pagina de sun: http://www.java.com/en/download/manual.jsp

b. Cambiar permisos del archivo descomprimido: chmod 777 jre-6u12-linux-i586.bin

c. Descomprimir el fichero bin: ./jre….bin

d. Hacer enlace simbólico:

Desde la carpeta /usr/lib/firefox-version/plugins . Para mirar la versión clikar en ayuda->acerca de firefox.

ln –s

Por ejemplo:

ln –s /root/jre-6u12-linux-i586/plugin/i386/ns7/libjavaplugin_oji.so

Ahora una vez en Webmin no se pedirá el plugin de java para por ejemplo en Otros>File system visualizar ficheros.

Si no se ven los ficheros java, instalarlo de la siguiente manera:

Herramientas > complementos > Obtener complementos > Buscar java e instalar la última versión y reiniciar firefox.


Servidor NFS

Instalar los paquetes siguientes:

  • apt-get install nfs-common
  • apt-get install nfs-kernel-server

SERVIDOR

Creamos una carpeta que queramos compartir. Cuidado con los permisos de la carpeta.
Ponemos chmod 777 nombre_carpeta_compartida para dar todos los permisos.

gedit /etc/export & y añadimos la ruta de la carpeta a compartir y después:

# /etc/exports: the access control list for filesystems which may be exported
# to NFS clients. See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes 192.168.1.2/255.255.255.0(rw,sync,no_root_squash)
#
# Example for NFSv4:
# /srv/nfs4 gss/krb5i(rw,sync,fsid=0,crossmnt)
# /srv/nfs4/homes gss/krb5i(rw,sync)
#
/home/ana/Escritorio/carp_compartida 192.168.1.2/255.255.255.0(rw,sync,no_root_squash)

Ponemos no_root_squash para dar todos los permisos al cliente.
En este fichero estarán todas las carpetas que queramos compartir a las diferentes ips.

Lanzamos los demonios

Ø /etc/init.d/portmap start

Ø /etc/init.d/nfs-kernel-server restart

NOTA: poner la ruta entera para no tener ningun problema.

Ahora ya podemos montar la carpeta del cliente donde queramos que se vayan las cosas compartidas.

CLIENTE

montamos la carpeta:
mount -t nfs ip_server:/ruta_carpeta_server /carpeta_local_donde_va_lo_compatido.

Ejemplo:
sudo mount -t nfs 192.168.1.3:/home/angel/Escritorio/carpetadeana /home/angel/Escritorio/Angel


Servidor Samba

1. Poner dirección IP

Servidor: 192.168.1.2

Cliente: 192.168.1.3

2. Instalar el servidor SAMBA:
apt-get install samba samba-common smbclient samba-doc smbfs


3. Instalar el entorno web para SAMBA:

apt-get install swat

4. Editar smb.conf en /etc/samba:

y añadir dentro del fichero :
***********************
[usuariosamba]
comment = Cosas para usuariosamba
path = /home/compartir
guest ok = no
browseable = yes
read only = no
create mask = 0770
directory mask = 0770
public=yes
***********************

5. Añadir usuario al sistema: adduser usuariosamba

6. Añadir password: passwd usuariosamba

7. Añadir usuario samba : smbpasswd –a usuariosamba

8. Lanzar el demonio: /etc/init.d/samba start/stop/restart

Cliente Samba

1. Abrir el explorador.

2. Introducir : smb://192.168.1.2 o en el explorer //192.168.1.2

3. Introducir usuario y contraseña.


Controlador de dominio Samba

Servidor

1. Poner dirección IP

Servidor: 192.168.1.2

Cliente: 192.168.1.3

2. Instalar el servidor SAMBA:
apt-get install samba samba-common smbclient samba-doc smbfs

3. Editar el fichero /etc/samba/smb.conf

[global]

netbios name = servidor

workgroup = MIDOMINIO

wins support = yes

os level = 64

preferred master = yes

domain master = yes

local master = yes

security = user

encrypt passwords = yes

domain logons = yes

[homes]

writable = yes

browseable = no

[netlogon]

path = /home/netlogon

read only = yes

4. Añadir a samba la cuenta de usuario root (SIN ESTO NO FUNCIONA) y asegurarse de poner la misma contraseña de root que en UNIX…

smbpasswd –a root

Añadir el equipo WINDOWS como usuario Unix. Para ver el nombre del pc de Windows XP, vamos a Panel de Control -> Sistema y pinchamos en la pestaña ``Nombre del equipo''. Es IMPORTANTISIMO poner el símbolo del dólar $!!!

Useradd –g MIDOMINIO –d /dev/null –s /bin/false NOMBRE_PC_XP$

Cambiamos las password… solo hay que ejecutar el comando:

Passwd –l NOMBRE_PC_XP$

Finalmente añadimos el equipo de Windows como usuario samba:

Smbpasswd –a –m NOMBRE_PC_XP

Por último reiniciamos el servicio: /etc/init.d/samba restart

Cliente Windows

Hay que hacer y comprobar los siguientes pasos:

  1. Ir a Panel de Control à Herramientas Administrativas à Directivas de Seguridad local à Directivas Locales à Opciones de seguridad
  2. Miembro de dominio: descifrar o firmar digitalmente datos de un canal seguro (siempre): Deshabilitar
  3. Miembro de dominio: Deshabilitar cambios password en cuenta máquina -> Deshabilitar
  4. Miembro de dominio: Requerir clave de sesión protegida (W2000 o más reciente) -> Deshabilitar

Agregar el cliente al dominio:

1. Vamos a Panel de Control à Sistema y pinchamos en la pestaña ``Nombre del equipo''.

2. Pincháis en el botón ``Cambiar''

3. Nombre del equipo: en nuestro ejemplo NOMBRE_PC_XP.

4. Miembro de: elegimos dominio.

5. El nombre del dominio es el nombre ``WorkGroup'' del archivo smb.conf, en nuestro caso MIDOMINIO

6. Le damos a aceptar y nos pide un usuario y una contraseña.

7. Hay que poner root (sí root) y la contraseña de root del servidor

8. Nos dará la bienvenida.

9. REINICIAR

10. FIN


Borrado, copia y restauración de router’s y switch’s

1. Borrado:

#erase startup-config

#delete flash:vlan.dat àBorra las VLAN que haya en el switch.

#reload

Poner ip a la vlan para conseguir conectividad con el equipo:

ena

configure terminal

interface vlan1

ip address 192.168.1.1 255.255.255.0

no shutdown

exit

exit

2. Copia del archivo de configuración:

Es necesario tener ftp activo, con, por ejemplo, SolanWinds_TFTP_Server.

#copy flash:tftp à1.Poner nombre fichero (show flash para ver el nombre)

3. Iniciar en modo romm con: (apagar y encender el router y pulsar CTRL+PAUSE)

#config-register 0x2142

ó

#confreg àAsignar la velocidad con 115200 para que tarde menos al hacer la copia y al cargar.

4. Restaurar el archivo de configuración:

Desde el modo romm ejecutamos:

#xmodem –c imagen.bin àAbrimos el hiperterminal y enviamos el archivo.


VLAN

1. Haremos la siguiente configuración:

1.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En cada PC se pondrá:

PC 1 àDirección: 192.168.1.2 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.1.3 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 3 àDirección: 192.168.1.4 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 4 àDirección: 192.168.1.5 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 5 àDirección: 192.168.1.6 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 6 àDirección: 192.168.1.7 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 7 àDirección: 192.168.1.8 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 8 àDirección: 192.168.1.9 P. enlace: 192.168.2.1 Máscara: 255.255.255.0


3. Creamos las VLAN’s y agregamos los puertos:

SWITCH1

SWITCH2

ena

vlan database

vlan 10 name ANGEL

vlan 20 name PEDRO

exit

show vlan

configure terminal

interface fastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/24

switchport mode trunk

exit

exit

ena

vlan database

vlan 10 name ANGEL

vlan 20 name PEDRO

exit

show vlan

configure terminal

interface fastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

exit

4. Ahora ya podremos hacer ping entre los PC’s de un mismo segmento o vlan pero no a los de una vlan distinta.

Es interesante para hacer esta práctica usar los comandos:

Show interfaces à muestra las interfaces indicando si están activas o no y sus características principales como su dirección y máscara si las tuviera.

Show running-config à Muestra la información de configuración del switch. Útil para comprobar si los datos de configuración introducidos son los correctos.

Show vlan à Muesta las vlan establecidas y sus puertos relacionados. Es importante comprobar con este comando las vlan que previamente a nuestra practica pudieran existir y que, por prevención, debemos eliminarlas, conociendo sus números relacionados:

Switch #no vlan


VTP SERVER Y VTP CLIENT

1. Haremos la siguiente configuración:

1.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En cada PC se pondrá:

PC 1 àDirección: 192.168.1.2 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.1.3 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 3 àDirección: 192.168.1.4 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 4 àDirección: 192.168.1.5 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 5 àDirección: 192.168.1.6 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 6 àDirección: 192.168.1.7 P. enlace: 192.168.2.1 Máscara: 255.255.255.0

PC 7 àDirección: 192.168.1.8 P. enlace: 192.168.1.1 Máscara: 255.255.255.0

PC 8 àDirección: 192.168.1.9 P. enlace: 192.168.2.1 Máscara: 255.255.255.0


3. Creamos las VLAN’s, agregamos los puertos y agregamos el servicio VTP:

VTP SERVER

VTP CLIENT

ena

vlan database

vlan 10 name ANGEL

vlan 20 name PEDRO

exit

show vlan

configure terminal

interface fastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

vtp mode server

vtp domain midominio

interface fastEthernet 0/24

switchport mode trunk

exit

exit

show vtp status

ena

configure terminal

vtp mode client

vtp domain midominio

interface fastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

exit

show vlan

show vtp status


Inter VLAN

1. Haremos la siguiente configuración:

1.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En cada PC se pondrá:

PC 1 àDirección: 192.168.10.2 P. enlace: 192.168.10.1 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.10.3 P. enlace: 192.168.10.1 Máscara: 255.255.255.0

PC 3 àDirección: 192.168.20.2 P. enlace: 192.168.20.1 Máscara: 255.255.255.0

PC 4 àDirección: 192.168.20.3 P. enlace: 192.168.20.1 Máscara: 255.255.255.0


4. Creamos las VLAN’s, agregamos los puertos y agregamos el servicio dot1q:

SWITCH

ena

vlan database

vlan 10 name ANGEL

vlan 20 name PEDRO

exit

show vlan

configure terminal

interface fastEthernet 0/1

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/2

switchport mode access

switchport access vlan 10

exit

interface fastEthernet 0/3

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/4

switchport mode access

switchport access vlan 20

exit

interface fastEthernet 0/24

switchport mode trunk

switchport trunk encapsulation dot1q

exit

exit

ROUTER

ena

configure terminal

interface fastEthernet 0/0

no shutdown

exit

interface fastEthernet 0/0.1

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

exit

interface fastEthernet 0/0.2

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

no shutdown

exit

exit


Spanning-tree

1. Haremos la siguiente configuración:

Cuadro de texto: LAZO

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En cada PC se pondrá:

PC 1 àDirección: 192.168.1.50 P. enlace: 192.168.10.1 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.1.51 P. enlace: 192.168.10.1 Máscara: 255.255.255.0

3. Configuramos los switch’s

ena

configure terminal

interface vlan 1

ip address 192.168.1.X 255.255.255.0

no shutdown

exit

interface fastethernet 0/X

shutdown

exit

no spanning-tree vlan 1

exit

write

show proc cpu

show mac_address_table

configure terminal

spanning-tree vlan 1

exit

write

show spaning-tree vlan 1

configure terminal

interface fastethernet 0/X

no shutdown

exit

show spaning-tree vlan 1

Ponemos IP a la VLAN… conectividad

Quitamos los lazos

Deshabilitamos Spanning-tree

Vemos que consume más cpu

Habilitamos spaning tree

Miramos información como el router raíz, el coste o la prioridad (DEFAULT=32769)

Habilitamos los lazos para ver que escoge el camino más corto

Miramos información como el router raíz, el coste o la prioridad (DEFAULT=32769)

4. Otros comandos

· Cambiar la prioridad al switch (La prioridad va de 4096 en 4096):

Spanning-tree vlan1 priority 4096

· Poner como root al switch

Spanning-tree vlan1 root primary

· Ver la sip y estados de las interfaces

Show ip interface brief

· Poner el puerto de la fastethernet x en modo portfast (más rapido)

Interface fastethernet X

Spanning portfast

· Cambiar el modo de spanning tree a rapid_pvst (ponerlo en todos los switch)

Spanning-tree mode rapid_pvst

· Cambiar al modo multispanning-tree y añadir varias vlan

Spanning-tree mode mst

Spanning-tree mst configuration

(config-mst)# instance vlan 1,2,3,4,…


NAT Estático y dinámico

1. Haremos la siguiente configuración:

2.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En el PC con NAT:

PC 1 àDirección: 10.10.10.10 P. enlace: 10.10.10.1 Máscara: 255.255.255.0


3. Configuramos el GATEWAY:

Estático

Dinámico

ena

configure terminal

ip route 0.0.0.0 0.0.0.0 200.2.2.17

interface fastEthernet 0/0

ip address 10.10.10.1 255.255.255.0

ip nat inside

no shutdown

exit

interface serial 0/0

ip address 200.2.2.18 255.255.255.252

clock rate 64000

ip nat outside

no shutdown

exit

ip nat pool public_access 199.99.9.33 199.99.9.39 netmask 255.255.255.224

access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source static 10.10.10.10 199.99.9.33

exit

show ip nat translation

ena

configure terminal

ip route 0.0.0.0 0.0.0.0 200.2.2.17

interface fastEthernet 0/0

ip address 10.10.10.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 200.2.2.18 255.255.255.252

clock rate 64000

no shutdown

exit

ip nat pool public-access 199.99.9.40 199.99.9.62 netmask 255.255.255.224

access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source list 1 pool public-access

interface fastEthernet 0/0

ip nat inside

exit

interface serial 0/0

ip nat outside

exit

exit

show ip nat translation

4. Configuramos el ISP

ena

configure terminal

ip route 199.99.9.32 255.255.255.224 200.2.2.18

interface loopback 0

ip address 172.16.1.1 255.255.255.255

no shutdown

exit

interface serial 0/0

ip address 200.2.2.17 255.255.255.252

no shutdown

exit

exit


NAT CON RIP

1. Haremos la siguiente configuración:

2.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En el PC con NAT:

PC 1 àDirección: 10.10.10.10 P. enlace: 10.10.10.1 Máscara: 255.255.255.0


3. Configuramos el GATEWAY:

Estático

Dinámico

ena

configure terminal

interface fastEthernet 0/0

ip address 10.10.10.1 255.255.255.0

ip nat inside

no shutdown

exit

interface serial 0/0

ip address 200.2.2.18 255.255.255.252

clock rate 64000

ip nat outside

no shutdown

exit

ip nat pool public_access 199.99.9.33 199.99.9.39 netmask 255.255.255.224

access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source static 10.10.10.10 199.99.9.33

router rip

network 10.10.10.1

network 200.2.2.18

exit

exit

show ip nat translation

ena

configure terminal

interface fastEthernet 0/0

ip address 10.10.10.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 200.2.2.18 255.255.255.252

clock rate 64000

no shutdown

exit

ip nat pool public-access 199.99.9.40 199.99.9.62 netmask 255.255.255.224

access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source list 1 pool public-access

interface fastEthernet 0/0

ip nat inside

exit

interface serial 0/0

ip nat outside

exit

router rip

network 10.10.10.1

network 200.2.2.18

exi

exit

show ip nat translation

4. Configuramos el ISP

ena

configure terminal

ip route 199.99.9.32 255.255.255.224 200.2.2.18

interface loopback 0

ip address 172.16.1.1 255.255.255.255

no shutdown

exit

interface serial 0/0

ip address 200.2.2.17 255.255.255.252

no shutdown

exit

router rip

network 200.2.2.17

network 172.16.1.1

exit

exit

RECUERDA HACER PING ENTRE LOS 2 PCS PARA QUE APAREZCA LA TABLA DE NAT AL HACER:

#show ip nat translation

NAT CON PUNTO DE ACCESO WIFFI

1. Configurar los routers con NAT como cualquiera de los ejercicios de NAT Anteriores

2. El punto de acceso debe tener la siguiente configuración (en la sala creo que lo hace solo):

IP: 10.10.10.2

Máscara: 255.255.255.0

Gateway: 10.10.10.1

3. Conectarnos al punto de acceso con las IP’s de siempre… 192.168.0.X

RECUERDA HACER PING ENTRE LOS 2 PCS PARA QUE APAREZCA LA TABLA DE NAT AL HACER:

#show ip nat translation

NAT/DHCP y OSPF

1. Haremos la siguiente configuración:

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

PC’s àDireccion por DHCP


3. Configuramos los routers:

Router1

Router2

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.0.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 172.16.1.1 255.255.255.252

clock rate 64000

no shutdown

exit

ip dhcp pool campus

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 172.16.1.2

exit

ip dhcp pool campus2

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 172.16.1.3

exit

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.1.1 192.168.1.10

router ospf 1

network 172.16.1.0 0.0.0.3 area 0

network 192.168.0.0 0.0.0.255 area 0

exit

ip nat pool public-access 199.99.9.40 199.99.9.62 netmask 255.255.255.224

access-list 1 permit 192.168.0.0 0.0.0.255

ip nat inside source list 1 pool public-access

interface fastEthernet 0/0

ip nat inside

exit

interface serial 0/0

ip nat outside

exit

exit

ena

configure terminal

ip route 199.99.9.32 255.255.255.224 172.16.1.1

interface serial 0/0

ip address 172.16.1.2 255.255.255.252

no shutdown

exit

interface fastEthernet 0/0

ip address 192.168.1.1 255.255.255.0

ip helper-address 172.16.1.1

no shutdown

exit

router ospf 1

network 172.16.1.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

exit

exit

RECUERDA HACER PING ENTRE LOS 2 PCS PARA QUE APAREZCA LA TABLA DE NAT AL HACER:

#show ip nat translation

DHCP-RELAY

1. Haremos la siguiente configuración:

1.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En el PC con NAT:

PC 1 àDireccion por DHCP

3. Configuramos los routers:

Router1 o CAMPUS

Router2 o ISP

ena

configure terminal

interface fastEthernet 0/0

ip address 172.16.12.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 172.16.1.6 255.255.255.252

clock rate 64000

no shutdown

exit

ip dhcp pool campus

network 172.16.12.0 255.255.255.0

default-router 172.16.12.1

dns-server 172.16.1.2

exit

ip dhcp excluded-address 172.16.12.1 172.16.12.10

router ospf 1

network 172.16.1.0 0.0.0.255 area 0

network 172.16.12.0 0.0.0.255 area 0

exit

ena

configure terminal

interface serial 0/0

ip address 172.16.1.5 255.255.255.252

no shutdown

exit

interface loopback 0

ip address 172.16.13.1 255.255.255.255

no shutdown

exit

ip dhcp pool isp

network 172.16.13.0 255.255.255.0

default-router 172.16.13.1

dns-server 172.16.1.2

exit

ip dhcp excluded-address 172.16.13.1 172.16.13.10

interface fastEthernet 0/0

ip helper-address 172.16.12.1

exit

router ospf 1

network 172.16.1.0 0.0.0.255 area 0

network 172.16.13.0 0.0.0.255 area 0

exit

DHCP y OSPF

1. Haremos la siguiente configuración:

4. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

PC’s àDireccion por DHCP

5. Configuramos los routers:

Router1

Router2

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.0.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 172.16.1.1 255.255.255.252

clock rate 64000

no shutdown

exit

ip dhcp pool campus

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 172.16.1.2

exit

ip dhcp pool campus2

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 172.16.1.3

exit

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.1.1 192.168.1.10

router ospf 1

network 172.16.1.0 0.0.0.3 area 0

network 192.168.0.0 0.0.0.255 area 0

exit

exit

ena

configure terminal

interface serial 0/0

ip address 172.16.1.2 255.255.255.252

no shutdown

exit

interface fastEthernet 0/0

ip address 192.168.1.1 255.255.255.0

ip helper-address 172.16.1.1

no shutdown

exit

router ospf 1

network 172.16.1.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

exit

exit

Encaminamiento por IP entre pcs

1. Haremos la siguiente configuración:

2. En el pc que actúa como encaminador, modificar el fichero /etc/sysctl.conf y poner el IP_FORWARD=1 y reiniciar el pc.

3. Comprobar que se hace ping del PC1 al PC2, que están en diferentes subredes.


Encaminamiento estático

4. Haremos la siguiente configuración:

3.bmp

5. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En el PC con NAT:

PC 1 àDirección: 192.168.0.2 P. enlace: 192.168.0.254 Máscara: 255.255.255.0

PC 2 àDirección: 172.16.0.2 P. enlace: 172.16.0.254 Máscara: 255.255.255.0

6. Configuramos los routers:

ROUTER1

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.0.254 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 200.10.10.1 255.255.255.252

no shutdown

exit

ip route 172.16.0.0 255.255.255.0 200.10.10.2

ip route 192.168.1.0 255.255.255.252 200.10.10.2

exit


ROUTER2

ena

configure terminal

interface serial 0/0

ip address 200.10.10.2 255.255.255.252

clock rate 64000

no shutdown

exit

interface serial 0/1

ip address 192.168.1.1 255.255.255.252

no shutdown

exit

ip route 172.16.0.0 255.255.255.0 192.168.1.2

ip route 192.168.0.0 255.255.255.0 200.10.10.1

exit

ROUTER3

ena

configure terminal

interface fastEthernet 0/0

ip address 172.16.0.254 255.255.255.0

no shutdown

exit

interface serial 0/1

ip address 192.168.1.2 255.255.255.252

clock rate 64000

no shutdown

exit

ip route 192.168.0.0 255.255.255.0 192.168.1.1

ip route 200.10.10.0 255.255.255.252 192.168.1.1

exit


OSPF

1. Haremos la siguiente configuración:

3.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

En el PC con NAT:

PC 1 àDirección: 192.168.1.2 P. enlace: 192.168.1.129 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.0.2 P. enlace: 192.168.0.1 Máscara: 255.255.255.0

3. Configuramos los routers:

ROUTER1

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.1.129 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 192.168.15.1 255.255.255.252

clock rate 64000

no shutdown

exit

router ospf 1

network 192.168.1.129 0.0.0.0 area 0

network 192.168.15.1 0.0.0.0 area 0

exit

exit


ROUTER2

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.0.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 192.168.15.2 255.255.255.252

no shutdown

exit

router ospf 1

network 192.168.0.1 0.0.0.0 area 0

network 192.168.15.2 0.0.0.0 area 0

exit

exit


RIP

1. Haremos la siguiente configuración:

3.bmp

2. Configuramos las direcciones de los PC’s

Inicio> Panel de control> Conexiones de red> Protocolo Internet à Propiedades

PC 1 àDirección: 192.168.1.2 P. enlace: 192.168.1.129 Máscara: 255.255.255.0

PC 2 àDirección: 192.168.0.2 P. enlace: 192.168.0.1 Máscara: 255.255.255.0

3. Configuramos los routers:

ROUTER1

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.1.129 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 192.168.15.1 255.255.255.252

clock rate 64000

no shutdown

exit

router rip

network 192.168.1.129

network 192.168.15.1

exit

exit

ROUTER2

ena

configure terminal

interface fastEthernet 0/0

ip address 192.168.0.1 255.255.255.0

no shutdown

exit

interface serial 0/0

ip address 192.168.15.2 255.255.255.252

no shutdown

exit

router rip

network 192.168.0.1

network 192.168.15.2

exit

exit


WIRELESS

Modo Bridge

Usaremos esta configuración para unir dos redes LAN cableadas separadas a una distancia a través de los puntos de acceso. Por lo que no podremos conectarnos a los punto de acceso una vez configurados.

Tarjeta Ethernet 1 (PC): Ip 192.168.0.10 netmask 255.255.255.0

Punto de acceso 1: - Ip 192.168.0.50

- Canal 1

- SSID: Es indiferente.

- Modo Bridge con la MAC de la tarjeta Ethernet del punto de acceso 2

Punto de acceso 2: - Ip 192.168.0.51

- Canal 1

- SSID: Es indiferente

- Modo Bridge con la MAC de la tarjeta Ethernet del punto de acceso 1

Tarjeta Ethernet 2 (PC): Ip 192.168.0.20 netmask 255.255.255.0

Cambiamos el modo en Advanced/Mode dentro de la página de configuración del punto de acceso.

Modo Wireless Client

Con este modo lo que conseguiremos es que la tarjeta Ethernet del PC y el punto de acceso se conviertan en una tarjeta wireless, de esta forma con el punto de acceso simulamos una tarjeta wireless en un equipo que sólo dispone de tarjeta Ethernet 10/100.

- Punto de acceso 1: Es el azul. En nuestro caso usaremos un punto de acceso como RINUEX que nos de acceso a Internet.

- Punto de acceso 2: El blanco. Lo pondremos en modo Client Wireless y le daremos a Site Survay para posteriormente buscar el punto de acceso que queremos asociarnos. Una vez dado a conectar, debe salirnos su dirección MAC en el campo correspondiente a Client Wireless.

- Tarjeta Ethernet (PC): al principio pondremos una ip y mascara de subred para que podamos acceder a la ip del punto de acceso. Una vez configurado el punto de acceso como Client Wireless, configuraremos la tarjeta de red Ethernet para que use el DHCP para recoger IP y DNS.

Modo Multipoint Bridge

Es un equivalente al modo bridge, con la diferencia de que en este caso no ponemos ninguna MAC, simplemente seleccionamos el modo Multipoint en el punto de acceso y ellos sólos se sincronizarán. Es imprescindible que los puntos de acceso estén en el mismo canal aunque los SSID pueden ser diferentes.

Tarjeta de red 1 (Lan segment 1): Ip: 192.168.0.60 netmask 255.255.255.0

Punto de acceso 1 (Lan segment 1):

- Canal: 1

- Modo Multipoint Bridge

- Ip: 192.168.0.50

Tarjeta de red 2 (Lan segment 2): Ip: 192.168.0.61 netmask 255.255.255.0

Punto de acceso 2 (Lan segment 2):

- Canal: 1

- Modo Multipoint Bridge

- Ip: 192.168.0.51

Tarjeta de red 3 (Lan segment 3): Ip: 192.168.0.62 netmask 255.255.255.0

Punto de acceso 3 (Lan segment 3):

- Canal: 1

- Modo Multipoint Bridge

- Ip: 192.168.0.52


Posible ejercicio de examen

Conectar a través del punto de acceso a Internet. La solución la pongo a mano:

alojamiento web gratis
Otros servicios ofrecidos por HispaVista:
Videos y Loterías
Consigue una página web gratis o un
alojamiento web profesional con Galeón